Slower than Normal Service
Incident Report for GroupDesk
Resolved
This incident has been resolved.
Posted Dec 30, 2019 - 15:22 EST
Update
Parts of Groupdesk are experiencing slower than normal service. This will result in a degraded service experience for some clients. The issue is currently being investigated.
Posted Dec 30, 2019 - 15:16 EST
Update
Parts of Groupdesk are experiencing slower than normal service. This will result in a degraded service experience for some clients. The issue is currently being investigated.
Posted Dec 30, 2019 - 15:16 EST
Investigating
Parts of Groupdesk are experiencing slower than normal service. This will result in a degraded service experience for some clients. The issue is currently being investigated.
Posted Dec 30, 2019 - 15:14 EST
This incident affected: GroupDesk API.