Slower than Normal Service
Incident Report for GroupDesk
Resolved
This incident has been resolved.
Posted Mar 05, 2020 - 13:44 EST
Investigating
Parts of Groupdesk are experiencing slower than normal service. This will result in a degraded service experience for some clients. The issue is currently being investigated.
Posted Mar 05, 2020 - 13:41 EST
This incident affected: GroupDesk API.