Partial Service Disruption
Incident Report for GroupDesk
Resolved
This incident has been resolved.
Posted Jan 06, 2020 - 17:07 EST
Update
Parts of Groupdesk are experiencing slower than normal service. This will result in a partial service disruption for some clients. The issue is currently being investigated.
Posted Jan 06, 2020 - 16:53 EST
Investigating
Parts of Groupdesk are experiencing slower than normal service. This will result in a partial service disruption for some clients. The issue is currently being investigated.
Posted Jan 06, 2020 - 16:45 EST
This incident affected: GroupDesk API.