Slower than Normal Service
Incident Report for GroupDesk
Resolved
This incident has been resolved.
Posted Aug 11, 2020 - 01:32 EDT
Update
Parts of Groupdesk are experiencing slower than normal service. This will result in a degraded service experience for some clients. The issue is currently being investigated.
Posted Aug 11, 2020 - 00:56 EDT
Investigating
Parts of Groupdesk are experiencing slower than normal service. This will result in a degraded service experience for some clients. The issue is currently being investigated.
Posted Aug 11, 2020 - 00:40 EDT
This incident affected: GroupDesk API.