Partial Service Disruption
Incident Report for GroupDesk
Resolved
This incident has been resolved.
Posted Aug 09, 2020 - 19:10 EDT
Update
Parts of Groupdesk are experiencing slower than normal service. This will result in a partial service disruption for some clients. The issue is currently being investigated.
Posted Aug 09, 2020 - 18:21 EDT
Investigating
Parts of Groupdesk are experiencing slower than normal service. This will result in a partial service disruption for some clients. The issue is currently being investigated.
Posted Aug 09, 2020 - 18:11 EDT
This incident affected: GroupDesk API.