Partial Service Disruption
Incident Report for GroupDesk
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 16:25 EDT
Investigating
Parts of Groupdesk are experiencing slower than normal service. This will result in a partial service disruption for some clients. The issue is currently being investigated.
Posted Mar 10, 2020 - 16:11 EDT
This incident affected: GroupDesk API.