Slower than Normal Service
Incident Report for GroupDesk
Resolved
This incident has been resolved.
Posted Apr 17, 2020 - 16:42 EDT
Update
Parts of Groupdesk are experiencing slower than normal service. This will result in a degraded service experience for some clients. The issue is currently being investigated.
Posted Apr 17, 2020 - 16:42 EDT
Investigating
Parts of Groupdesk are experiencing slower than normal service. This will result in a degraded service experience for some clients. The issue is currently being investigated.
Posted Apr 17, 2020 - 16:40 EDT
This incident affected: GroupDesk API.